Reg Organizer stuck when making snapshot

Questions and comments regarding Reg Organizer, Registry Life and Autorun Organizer.
User avatar
Chemtable Software
Developers Team
Posts: 380
Joined: Thu Aug 07, 2008 12:59 pm

Re: Reg Organizer stuck when making snapshot

Post by Chemtable Software »

Hi,

Yes, the problem is strange (and interesting). If you manually reset this value to (not set), will the problem occur again? Or do you mean that to reproduce it, you need to restore the registry to the state it was in when this value was not set, e.g. using System Restore, i.e. it no longer reproduces?
Dobrus
Posts: 13
Joined: Wed Aug 02, 2023 6:58 pm

Re: Reg Organizer stuck when making snapshot

Post by Dobrus »

Hi, yes the problem occurs again if I change back to "value not set" (simply by deleting "(Default)" entry). This surprises me because the rest of the registry entries have "Default" set to "value not set" and nowhere else does this type of error occur. The problem is only with the key "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control" and "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control" (they are probably linked because a change to one of the entries also affects the other) which is what Reg Organizer had the problem with. Regards.
User avatar
Chemtable Software
Developers Team
Posts: 380
Joined: Thu Aug 07, 2008 12:59 pm

Re: Reg Organizer stuck when making snapshot

Post by Chemtable Software »

Hi,

The problem is probably due to a some driver somehow using the default value of this key (\Control). It seems to be creating and removing this value frequently.

Using the log files you sent us, we have found a problem in our code that can lead to the changes tracing error (when the WinAPI registry access function returns ERROR_FILE_NOT_FOUND, which it does for the above key). This issue has been fixed in the build below, it should no longer hang. We would be grateful if you could test it when the default value of the \Control key is not set, i.e. when the problem is reproducible:

https://files.chemtable.com/special/Reg ... gDemo6.zip
Dobrus
Posts: 13
Joined: Wed Aug 02, 2023 6:58 pm

Re: Reg Organizer stuck when making snapshot

Post by Dobrus »

You were right, this time the test was successful. Log is in attachment.
OnFirstSnapshotComplete: 1
Dt = 6735 ms
KeysValues / Sec. = 155934.37
MaxKeysValues = 1050218
Is there any way to trace which driver might be causing this behaviour? Regards.
You do not have the required permissions to view the files attached to this post.
User avatar
Chemtable Software
Developers Team
Posts: 380
Joined: Thu Aug 07, 2008 12:59 pm

Re: Reg Organizer stuck when making snapshot

Post by Chemtable Software »

Hi,

Glad to hear that the problem no longer occurs!
It was because some driver is removing the registry value in HKLM\...\Control between the two calls to the RegQueryValueExW WinAPI function. This change probably happens in nanoseconds! Only a driver that filters the registry can do this. Our application was not ready to handle such situation.
The only thing that isn't clear is which application driver is doing this on your system (and why).
Thank you for your help in investigating this issue!
Dobrus
Posts: 13
Joined: Wed Aug 02, 2023 6:58 pm

Re: Reg Organizer stuck when making snapshot

Post by Dobrus »

Thank you for your time and for all your help in locating the problem. The important thing is that the RO is working as it should, and maybe one day I'll be able to figure out what exactly is causing this behaviour. But for now I won't bother with that, we've spent a lot of time on it ;) thank you again and best regards.
chemzinho
Posts: 1
Joined: Sun Mar 03, 2024 8:05 pm

Re: Reg Organizer stuck when making snapshot

Post by chemzinho »

I have been using Reg Organizer since 2020 and have never been able to use the application installation function with tracking for the same reason, and indeed version 9.30 (09/20/2023) fixed this problem for me. I was really curious about what caused this as well. It seems we have a common driver.